<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#" class="html_stretched responsive av-preloader-disabled av-default-lightbox  html_header_top html_logo_left html_main_nav_header html_menu_right html_large html_header_sticky html_header_shrinking_disabled html_header_topbar_active html_mobile_menu_phone html_disabled html_header_searchicon html_content_align_center html_header_unstick_top_disabled html_header_stretch html_entry_id_13440 ">
<head>
<meta charset="UTF-8"/>


<!-- mobile setting -->
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">

<!-- Scripts/CSS and wp_head hook -->
<title>Men in Black Basketball - Diocese of Rapid City</title>

<!-- This site is optimized with the Yoast SEO plugin v4.2.1 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://rapidcitydiocese.org/men-black-basketball/"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="article"/>
<meta property="og:title" content="Men in Black Basketball - Diocese of Rapid City"/>
<meta property="og:url" content="http://rapidcitydiocese.org/men-black-basketball/"/>
<meta property="og:site_name" content="Diocese of Rapid City"/>
<meta property="article:section" content="Media"/>
<meta property="article:published_time" content="2017-02-09T16:25:46-07:00"/>
<meta property="article:modified_time" content="2017-02-09T16:54:21-07:00"/>
<meta property="og:updated_time" content="2017-02-09T16:54:21-07:00"/>
<meta property="og:image" content="http://rapidcitydiocese.org/wp-content/uploads/2016/01/MIBLogo4.jpg"/>
<meta property="og:image:width" content="450"/>
<meta property="og:image:height" content="302"/>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="Diocese of Rapid City &raquo; Feed" href="http://rapidcitydiocese.org/feed/"/>
<link rel="alternate" type="application/rss+xml" title="Diocese of Rapid City &raquo; Comments Feed" href="http://rapidcitydiocese.org/comments/feed/"/>

<!-- google webfont font replacement -->
<link rel='stylesheet' id='avia-google-webfont' href='//fonts.googleapis.com/css?family=Open+Sans:400,600' type='text/css' media='all'/> 
		<script type="text/javascript">window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/rapidcitydiocese.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.2"}};!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);</script>
		<style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-.1em!important;background:none!important;padding:0!important}</style>
<style id='rotatingtweets-css' media='all'>div.rotatingtweet{font-size:100%;word-wrap:break-word;vertical-align:top}div.cycle-carousel-wrap div.rotatingtweet{padding-right:1em}p.rtw_meta,div.rtw_meta,div.rtw_meta_wide,div.rtw_name,div.rtw_id,div.rtw_time_short,div.rtw_rt_meta{font-size:.8em;line-height:normal;white-space:normal}div.rtw_wide_block div.rtw_name{font-size:1.0em}div.rtw_icon img{max-width:2.2em;max-height:2.2em}div.rtw_intents a img,span.rtw_intents a img{max-width:1.2em;max-height:1.2em;padding:0;margin:0;display:inline}div.rtw_wide_icon img{padding-top:8%;padding-left:0;margin-left:0}div.rtw_meta img,div.rtw_rt_meta img{vertical-align:middle}.rtw_twitter_icon,.rtw_time_short{float:right}div.rtw_wide_icon,div.rtw_icon{float:left;padding-right:.5em}div.rtw_wide_icon{display:inline}.rtw_wide_block .rtw_name,.rtw_wide_block .rtw_id{display:inline}.rtw_wide_block{padding-left:58px}div.rtw_intents{display:inline;float:right;margin-left:.5em}div.rtw_intents a,span.rtw_intents a{display:inline}div.rtw_timestamp{display:inline}.rotatingtweet p.rtw_main{clear:both}.rtw_wide_block p.rtw_main,div.rtw_main{clear:none}.norotatingtweets .rotatingtweet{border-bottom:1px solid #ddd}.rtw_media{clear:both}.rtw_media img{margin:auto;height:150px;max-height:150px}.rtw_pager{text-align:center;font-size:2em}.rtw_pager a{text-decoration:none!important}.rtw_pager .cycle-pager-active,.rtw_pager .activeSlide{color:#ddd}#content .rotatingtweets,#content .norotatingtweets{border-top:1px solid #ddd;border-bottom:1px solid #ddd;margin-bottom:3%}#content .rotatingtweet{padding-top:.7em;padding-bottom:.7em}#content p.rtw_main,p.rtw_main,div.rtw_main{margin-bottom:.6em;white-space:normal}#content .rtw_wide p.rtw_main{margin-bottom:.35em}p.rtw_meta,div.rtw_meta{margin-bottom:1em}#sidebar ul li div.rtw_name,div.rtw_name,div.rtw_name a{margin-bottom:0;padding-bottom:0}#sidebar ul li div.rtw_id,div.rtw_id,div.rtw_id a{margin-top:0;padding-top:0}#sidebar ul li div.rtw_intents{margin-top:0;padding-top:0}div.rtw_rt_meta{margin-top:.1em;margin-bottom:.1em;padding:0}</style>
<link rel='stylesheet' id='dashicons-css' href='http://rapidcitydiocese.org/wp-includes/css/dashicons.min.css,qver=4.7.2.pagespeed.ce.zzwOjyb-IC.css' type='text/css' media='all'/>
<link rel='stylesheet' id='wolf-jplayer-css' href='http://rapidcitydiocese.org/wp-content/plugins/wolf-jplayer/assets/css/min/jplayer-default.min.css,qver=2.1.7.3.pagespeed.ce.UQ5H1q_c8g.css' type='text/css' media='all'/>
<link rel='stylesheet' id='avia-grid-css' href='http://rapidcitydiocese.org/wp-content/themes/enfold/css/A.grid.css,qver=2.pagespeed.cf.RMbRg_TGTK.css' type='text/css' media='all'/>
<link rel='stylesheet' id='avia-base-css' href='http://rapidcitydiocese.org/wp-content/themes/enfold/css/A.base.css,qver=2.pagespeed.cf.FjDjeq-ant.css' type='text/css' media='all'/>
<link rel='stylesheet' id='avia-layout-css' href='http://rapidcitydiocese.org/wp-content/themes/enfold/css/A.layout.css,qver=2.pagespeed.cf.HdDxBKlYq6.css' type='text/css' media='all'/>
<link rel='stylesheet' id='avia-scs-css' href='http://rapidcitydiocese.org/wp-content/themes/enfold/css/A.shortcodes.css,qver=2.pagespeed.cf.e1ljoNgrXZ.css' type='text/css' media='all'/>
<link rel='stylesheet' id='avia-popup-css-css' href='http://rapidcitydiocese.org/wp-content/themes/enfold/js/aviapopup/A.magnific-popup.css,qver=1.pagespeed.cf.EpQUyr7sbe.css' type='text/css' media='screen'/>
<link rel='stylesheet' id='avia-media-css' href='http://rapidcitydiocese.org/wp-content/themes/enfold/js/mediaelement/skin-1/A.mediaelementplayer.css,qver=1.pagespeed.cf.UQ9F7cMs18.css' type='text/css' media='screen'/>
<link rel='stylesheet' id='avia-print-css' href='http://rapidcitydiocese.org/wp-content/themes/enfold/css/A.print.css,qver=1.pagespeed.cf.NaXFZdnSKN.css' type='text/css' media='print'/>
<link rel='stylesheet' id='avia-dynamic-css' href='http://rapidcitydiocese.org/wp-content/uploads/dynamic_avia/A.enfold.css,qver=5851c76f43c1e.pagespeed.cf.XUMXaVz78t.css' type='text/css' media='all'/>
<style id='avia-custom-css' media='all'></style>
<link rel='stylesheet' id='evcal_google_fonts-css' href='//fonts.googleapis.com/css?family=Oswald%3A400%2C300%7COpen+Sans%3A400%2C300&#038;ver=4.7.2' type='text/css' media='screen'/>
<link rel='stylesheet' id='evcal_cal_default-css' href='//rapidcitydiocese.org/wp-content/plugins/eventON/assets/css/A.eventon_styles.css,qver=2.4.3.pagespeed.cf.wHrbapzFrx.css' type='text/css' media='all'/>
<link rel='stylesheet' id='evo_font_icons-css' href='//rapidcitydiocese.org/wp-content/plugins/eventON/assets/fonts/A.font-awesome.css,qver=4.6.2.pagespeed.cf.ZLWc8-MTi8.css' type='text/css' media='all'/>
<link rel='stylesheet' id='tablepress-default-css' href='http://rapidcitydiocese.org/wp-content/plugins/tablepress/css/default.min.css,qver=1.7.pagespeed.ce.7xkvLK1IWv.css' type='text/css' media='all'/>
<style id='tablepress-default-inline-css' type='text/css'>.tablepress thead th{background-color:#003f0d;color:#fff}</style>
<script type='text/javascript' src='http://rapidcitydiocese.org/wp-includes/js/jquery/jquery.js,qver=1.12.4.pagespeed.jm.pPCPAKkkss.js'></script>
<script type='text/javascript' src='http://rapidcitydiocese.org/wp-includes/js/jquery/jquery-migrate.min.js,qver=1.4.1.pagespeed.jm.C2obERNcWh.js'></script>
<script type='text/javascript'>"use strict"
var avia_is_mobile=false;if(/Android|webOS|iPhone|iPad|iPod|BlackBerry|IEMobile|Opera Mini/i.test(navigator.userAgent)&&'ontouchstart'in document.documentElement){avia_is_mobile=true;document.documentElement.className+=' avia_mobile ';}else{document.documentElement.className+=' avia_desktop ';}document.documentElement.className+=' js_active ';(function(){var prefix=['-webkit-','-moz-','-ms-',""],transform="";for(var i in prefix){if(prefix[i]+'transform'in document.documentElement.style){document.documentElement.className+=" avia_transform ";transform=prefix[i]+'transform'}if(prefix[i]+'perspective'in document.documentElement.style)document.documentElement.className+=" avia_transform3d ";}if(typeof document.getElementsByClassName=='function'&&typeof document.documentElement.getBoundingClientRect=="function"&&avia_is_mobile==false){if(transform&&window.innerHeight>0){setTimeout(function(){var y=0,offsets={},transY=0,parallax=document.getElementsByClassName("av-parallax"),winTop=window.pageYOffset||document.documentElement.scrollTop;for(y=0;y<parallax.length;y++){parallax[y].style.top="0px";offsets=parallax[y].getBoundingClientRect();transY=Math.ceil((window.innerHeight+winTop-offsets.top)*0.3);parallax[y].style[transform]="translate(0px, "+transY+"px)";parallax[y].style.top="auto";parallax[y].className+=' enabled-parallax ';}},50);}}})();</script>
<link rel='https://api.w.org/' href='http://rapidcitydiocese.org/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://rapidcitydiocese.org/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://rapidcitydiocese.org/wp-includes/wlwmanifest.xml"/> 
<meta name="generator" content="WordPress 4.7.2"/>
<link rel='shortlink' href='http://rapidcitydiocese.org/?p=13440'/>
<link rel="alternate" type="application/json+oembed" href="http://rapidcitydiocese.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Frapidcitydiocese.org%2Fmen-black-basketball%2F"/>
<link rel="alternate" type="text/xml+oembed" href="http://rapidcitydiocese.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Frapidcitydiocese.org%2Fmen-black-basketball%2F&#038;format=xml"/>
<style type="text/css">.wolf-jplayer-playlist-container,.wolf-jplayer-playlist a{color:#006b1d!important}.wolf-jplayer-playlist .jp-play-bar,.wolf-jplayer-playlist .jp-volume-bar-value{background-color:#006b1d}.wolf-jplayer-loader-overlay{background-color:#fff}.wolf-jplayer-playlist-container{background-color:rgba(255,255,255,1)}.wolf-jplayer-playlist-container .mCSB_scrollTools .mCSB_dragger_bar{background-color:#006b1d}</style><link rel="profile" href="http://gmpg.org/xfn/11"/>
<link rel="alternate" type="application/rss+xml" title="Diocese of Rapid City RSS2 Feed" href="http://rapidcitydiocese.org/feed/"/>
<link rel="pingback" href="http://rapidcitydiocese.org/xmlrpc.php"/>
<!--[if lt IE 9]><script src="http://rapidcitydiocese.org/wp-content/themes/enfold/js/html5shiv.js"></script><![endif]-->
<link rel="icon" href="http://rapidcitydiocese.org/wp-content/uploads/2014/06/xCrest14.png.pagespeed.ic.k73nzwDvWG.png" type="image/png">


<!-- EventON Version -->
<meta name="generator" content="EventON 2.4.3"/>


<!-- BEGIN GADWP v4.9.6.1 Universal Tracking - https://deconf.com/google-analytics-dashboard-wordpress/ -->
<script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');ga('create','UA-62402157-1','auto');ga('send','pageview');</script>

<!-- END GADWP Universal Tracking -->



<!--
Debugging Info for Theme support: 

Theme: Enfold
Version: 3.8.4
Installed: enfold
AviaFramework Version: 4.6
AviaBuilder Version: 0.9.4
ML:768-PU:44-PLA:16
WP:4.7.2
Updates: enabled
-->

<style type='text/css'>@font-face{font-family:'entypo-fontello';font-weight:normal;font-style:normal;src:url(http://rapidcitydiocese.org/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.eot?v=3);src:url(http://rapidcitydiocese.org/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.eot?v=3#iefix) format('embedded-opentype') , url(http://rapidcitydiocese.org/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.woff?v=3) format('woff') , url(http://rapidcitydiocese.org/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.ttf?v=3) format('truetype') , url(http://rapidcitydiocese.org/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.svg?v=3#entypo-fontello) format('svg')}@font-face{font-family:'fontello';font-weight:normal;font-style:normal;src:url(http://rapidcitydiocese.org/wp-content/uploads/avia_fonts/fontello/fontello.eot);src:url(http://rapidcitydiocese.org/wp-content/uploads/avia_fonts/fontello/fontello.eot?#iefix) format('embedded-opentype') , url(http://rapidcitydiocese.org/wp-content/uploads/avia_fonts/fontello/fontello.woff) format('woff') , url(http://rapidcitydiocese.org/wp-content/uploads/avia_fonts/fontello/fontello.ttf) format('truetype') , url(http://rapidcitydiocese.org/wp-content/uploads/avia_fonts/fontello/fontello.svg#fontello) format('svg')}#top .avia-font-entypo-fontello,body .avia-font-entypo-fontello,html body [data-av_iconfont="entypo-fontello"]:before{font-family:'entypo-fontello'}#top .avia-font-fontello,body .avia-font-fontello,html body [data-av_iconfont="fontello"]:before{font-family:'fontello'}</style>
</head>




<body id="top" class="post-template-default single single-post postid-13440 single-format-standard stretched open_sans " itemscope="itemscope" itemtype="https://schema.org/WebPage">

	
	<div id='wrap_all'>

	
<header id='header' class='all_colors header_color light_bg_color  av_header_top av_logo_left av_main_nav_header av_menu_right av_large av_header_sticky av_header_shrinking_disabled av_header_stretch av_mobile_menu_phone av_header_searchicon av_header_unstick_top_disabled av_bottom_nav_disabled  av_alternate_logo_active av_header_border_disabled' role="banner" itemscope="itemscope" itemtype="https://schema.org/WPHeader">

<a id="advanced_menu_toggle" href="#" aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'></a><a id="advanced_menu_hide" href="#" aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'></a>		<div id='header_meta' class='container_wrap container_wrap_meta  av_icon_active_right av_extra_header_active av_secondary_right av_phone_active_right av_entry_id_13440'>
		
			      <div class='container'>
			      <ul class='noLightbox social_bookmarks icon_count_3'><li class='social_bookmarks_twitter av-social-link-twitter social_icon_1'><a target='_blank' href='https://twitter.com/RapidCitydiorc' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello' title='Twitter'><span class='avia_hidden_link_text'>Twitter</span></a></li><li class='social_bookmarks_facebook av-social-link-facebook social_icon_2'><a target='_blank' href='https://www.facebook.com/DioceseofRapidCity' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello' title='Facebook'><span class='avia_hidden_link_text'>Facebook</span></a></li><li class='social_bookmarks_youtube av-social-link-youtube social_icon_3'><a target='_blank' href='https://www.youtube.com/channel/UCIuQQIrfjEcg0pUJqSOdB9Q' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello' title='Youtube'><span class='avia_hidden_link_text'>Youtube</span></a></li></ul><div class='phone-info '><span> <a href="https://www.eservicepayments.com/cgi-bin/Vanco_ver3.vps?appver3=Fi1giPL8kwX_Oe1AO50jRibGURMPi-E9Ef_Hk0w0AR5EOVZpPcIw91FrYieK2rA42EvVVAEjqawDomKT1pboucHPJPNpSxsumnSKx7uzRSc=&ver=3" target="_blank">Donate Now</a> </span></div>			      </div>
		</div>

		<div id='header_main' class='container_wrap container_wrap_logo'>
	
        <div class='container av-logo-container'><div class='inner-container'><strong class='logo'><a href='http://rapidcitydiocese.org/'><img height='100' width='300' src='http://www.rapidcitydiocese.org/wp-content/uploads/2016/07/FINALLogoDark.png' alt='Diocese of Rapid City'/></a></strong><nav class='main_menu' data-selectname='Select a page' role="navigation" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement"><div class="avia-menu av-main-nav-wrap"><ul id="avia-menu" class="menu av-main-nav"><li id="menu-item-11996" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-top-level menu-item-top-level-1"><a href="http://www.rapidcitydiocese.org/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Home</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li>
<li id="menu-item-6829" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-mega-parent  menu-item-top-level menu-item-top-level-2"><a href="http://rapidcitydiocese.org/im-new/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">I&#8217;m New</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li>
<li id="menu-item-7431" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-mega-parent  menu-item-top-level menu-item-top-level-3"><a href="#" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Who We Are</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a>
<div class='avia_mega_div avia_mega2 six units'>

<ul class="sub-menu">
	<li id="menu-item-7110" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children avia_mega_menu_columns_2 three units  avia_mega_menu_columns_first"><span class='mega_menu_title heading-color av-special-font'>Who we are</span>
	<ul class="sub-menu">
		<li id="menu-item-7111" class="avia_mega_text_block menu-item menu-item-type-custom menu-item-object-custom">Learn more about the diocese, our mission and our staff.</li>
	</ul>
</li>
	<li id="menu-item-7417" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children avia_mega_menu_columns_2 three units avia_mega_menu_columns_last">
	<ul class="sub-menu">
		<li id="menu-item-7127" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/what-we-believe/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">What We Believe</span></a></li>
		<li id="menu-item-6647" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/about-us/personnel/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Personnel</span></a></li>
		<li id="menu-item-7670" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/parishes/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Parishes</span></a></li>
		<li id="menu-item-7348" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/diocesan-history/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Diocesan History</span></a></li>
	</ul>
</li>
</ul>

</div>
</li>
<li id="menu-item-11997" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-top-level menu-item-top-level-4"><a href="http://rapidcitydiocese.org/parishes/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Parishes</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li>
<li id="menu-item-6727" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-mega-parent  menu-item-top-level menu-item-top-level-5"><a href="http://rapidcitydiocese.org/what-we-do/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">What We Do</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a>
<div class='avia_mega_div avia_mega5 twelve units'>

<ul class="sub-menu">
	<li id="menu-item-7334" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children avia_mega_menu_columns_5 three units  avia_mega_menu_columns_first"><span class='mega_menu_title heading-color av-special-font'>Administration</span>
	<ul class="sub-menu">
		<li id="menu-item-7346" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/office-of-bishop/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Office of Bishop</span></a></li>
		<li id="menu-item-7361" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/office-of-vicar-general/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Office of Vicar General</span></a></li>
		<li id="menu-item-9903" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/office-of-vicar-for-clergy/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Office of Vicar for Clergy</span></a></li>
		<li id="menu-item-7287" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/chancellor/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Chancellor</span></a></li>
		<li id="menu-item-13389" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/tribunal/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Tribunal</span></a></li>
		<li id="menu-item-7347" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/office-of-bishop/councils-and-commisions/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Councils and Commissions</span></a></li>
		<li id="menu-item-7411" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/chancellor/employment/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Employment</span></a></li>
		<li id="menu-item-7363" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/office-of-vicar-general/facilities/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Facilities</span></a></li>
		<li id="menu-item-7369" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/chancellor/archives/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Archives</span></a></li>
		<li id="menu-item-7813" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/safe-environment/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Safe Environment</span></a></li>
	</ul>
</li>
	<li id="menu-item-7239" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children avia_mega_menu_columns_5 three units "><span class='mega_menu_title heading-color av-special-font'>Evangelization</span>
	<ul class="sub-menu">
		<li id="menu-item-6969" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/faith-formation/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Faith Formation</span></a></li>
		<li id="menu-item-10164" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/yya/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Youth and Young Adult Ministry</span></a></li>
		<li id="menu-item-11125" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/family-life-ministries-social-justice/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Family Life Ministries</span></a></li>
		<li id="menu-item-7172" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/native-ministry/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Native Ministry</span></a></li>
		<li id="menu-item-9179" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/sioux-spiritual-center/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Sioux Spiritual Center</span></a></li>
		<li id="menu-item-12689" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/stewardship/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Stewardship</span></a></li>
		<li id="menu-item-7399" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/lay-ministry-formation/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Lay Ministry Formation</span></a></li>
		<li id="menu-item-8148" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/office-worship-liturgy/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Office of Worship and Liturgy</span></a></li>
		<li id="menu-item-8782" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/propagation-of-faith/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Propagation of Faith</span></a></li>
	</ul>
</li>
	<li id="menu-item-7349" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children avia_mega_menu_columns_5 three units "><span class='mega_menu_title heading-color av-special-font'>Communications</span>
	<ul class="sub-menu">
		<li id="menu-item-7286" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/communications/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Communications</span></a></li>
		<li id="menu-item-7265" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/west-river-catholic/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">West River Catholic</span></a></li>
		<li id="menu-item-7414" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/communications/media/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Social Media</span></a></li>
	</ul>
</li>
	<li id="menu-item-7370" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children avia_mega_menu_columns_5 three units "><span class='mega_menu_title heading-color av-special-font'>Vocations</span>
	<ul class="sub-menu">
		<li id="menu-item-7214" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/vocations/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Vocations</span></a></li>
		<li id="menu-item-7400" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/permanent-diaconate/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Permanent Diaconate</span></a></li>
	</ul>
</li>
	<li id="menu-item-7403" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children avia_mega_menu_columns_5 three units avia_mega_menu_columns_last"><span class='mega_menu_title heading-color av-special-font'>Fiscal Services</span>
	<ul class="sub-menu">
		<li id="menu-item-7409" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/finance/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Finance</span></a></li>
		<li id="menu-item-8144" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://rapidcitydiocese.org/development/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Development</span></a></li>
	</ul>
</li>
</ul>

</div>
</li>
<li id="menu-item-8897" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-top-level menu-item-top-level-6"><a href="http://rapidcitydiocese.org/event-directory/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Events</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li>
<li id="menu-item-7658" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-top-level menu-item-top-level-7"><a href="http://rapidcitydiocese.org/links/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Links</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li>
<li id="menu-item-11998" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-top-level menu-item-top-level-8"><a target="_blank" href="https://www.eservicepayments.com/cgi-bin/Vanco_ver3.vps?appver3=Fi1giPL8kwX_Oe1AO50jRibGURMPi-E9Ef_Hk0w0AR5EOVZpPcIw91FrYieK2rA42EvVVAEjqawDomKT1pboucHPJPNpSxsumnSKx7uzRSc=&amp;ver=3" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Make a Gift</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li>
<li id="menu-item-search" class="noMobile menu-item menu-item-search-dropdown menu-item-avia-special">
							<a href="?s=" data-avia-search-tooltip="

&lt;form action=&quot;http://rapidcitydiocese.org/&quot; id=&quot;searchform&quot; method=&quot;get&quot; class=&quot;&quot;&gt;
	&lt;div&gt;
		&lt;input type=&quot;submit&quot; value=&quot;&quot; id=&quot;searchsubmit&quot; class=&quot;button avia-font-entypo-fontello&quot; /&gt;
		&lt;input type=&quot;text&quot; id=&quot;s&quot; name=&quot;s&quot; value=&quot;&quot; placeholder='Search' /&gt;
			&lt;/div&gt;
&lt;/form&gt;" aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'><span class="avia_hidden_link_text">Search</span></a>
	        		   </li></ul></div></nav></div> </div> 
		<!-- end container_wrap-->
		</div>
		
		<div class='header_bg'></div>

<!-- end header -->
</header>
		
	<div id='main' class='all_colors' data-scroll-offset='116'>

	<div class='stretch_full container_wrap alternate_color dark_bg_color title_container'><div class='container'><h1 class='main-title entry-title'><a href='http://rapidcitydiocese.org/men-black-basketball/' rel='bookmark' title='Permanent Link: Men in Black Basketball' itemprop="headline">Men in Black Basketball</a></h1><div class="breadcrumb breadcrumbs avia-breadcrumbs"><div class="breadcrumb-trail" xmlns:v="http://rdf.data-vocabulary.org/#"><span class="trail-before"><span class="breadcrumb-title">You are here:</span></span> <a href="http://rapidcitydiocese.org" title="Diocese of Rapid City" rel="home" class="trail-begin">Home</a> <span class="sep">/</span> <span><a rel="v:url" property="v:title" href="http://rapidcitydiocese.org/blog/" title="News">News</a></span> <span class="sep">/</span> <span><a rel="v:url" property="v:title" href="http://rapidcitydiocese.org/category/media/">Media</a></span> <span class="sep">/</span> <span class="trail-end">Men in Black Basketball</span></div></div></div></div><div class='main_color container_wrap_first container_wrap sidebar_right'><div class='container'><main role="main" itemscope="itemscope" itemtype="https://schema.org/Blog" class='template-page content  av-content-small alpha units'><div class='post-entry post-entry-type-page post-entry-13440'><div class='entry-content-wrapper clearfix'><section class="av_textblock_section" itemscope="itemscope" itemtype="https://schema.org/BlogPosting" itemprop="blogPost"><div class='avia_textblock ' itemprop="text"><p>Photos from the 2017 Men in Black basketball game. The event is co-sponsored by the Rapid City Catholic School System and the Vocations Office as a way for the people of the diocese to meet some of the priests and seminarians in a fun and entertaining environment.</p>
<p>The evening also serves as a fund-raiser for the St. Thomas More Mission Team. <span class="s1">Every year, over the Easter break, a team of juniors and seniors from Saint Thomas More High School go on a mission trip — the past four years have working with the Mustard Seed Communities in Jamaica. MSC is a Catholic organization that has built orphanages all over the world which house mentally and physically handicapped children and young adults. Each year students raise money for a specific project which will benefit the communities. This year the mission team is partnering with Hope Haven international to purchase new wheelchairs for some of the residents. The money raised during the men in black basketball game helped meet the monetary goal for this project. </span></p>
</div></section>
<div class='avia-gallery avia-gallery-1 avia_lazyload avia_animate_when_visible  avia-builder-el-1  el_after_av_textblock  avia-builder-el-last ' itemscope="itemscope" itemtype="https://schema.org/ImageObject"><a class='avia-gallery-big fakeLightbox lightbox avia-gallery-big-no-crop-thumb ' href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3810-1030x687.jpg' data-onclick='1' title=''><span class='avia-gallery-big-inner' itemprop="contentURL">	<img width='1200' height='800' src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3810.jpg' title='BH3A3810' alt=''/></span></a><div class='avia-gallery-thumb'> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3810-1030x687.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3810.jpg' class='first_thumb lightbox ' data-onclick='1' title='' itemprop="contentURL"><img src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3810-260x185.jpg' width='260' height='185' title='BH3A3810' alt=''/></a> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3691-1030x686.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3691.jpg' class='lightbox ' data-onclick='2' title='St. Elizabeth Seton Students vs. teachers' itemprop="contentURL"><img data-avia-tooltip='St. Elizabeth Seton Students vs. teachers' src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3691-260x185.jpg' width='260' height='185' title='BH3A3691' alt=''/></a> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3695-687x1030.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3695.jpg' class='lightbox ' data-onclick='3' title='St. Elizabeth Seton Students vs. teachers' itemprop="contentURL"><img data-avia-tooltip='St. Elizabeth Seton Students vs. teachers' src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3695-260x185.jpg' width='260' height='185' title='BH3A3695' alt=''/></a> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3697-687x1030.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3697.jpg' class='lightbox ' data-onclick='4' title='St. Elizabeth Seton Students vs. teachers' itemprop="contentURL"><img data-avia-tooltip='St. Elizabeth Seton Students vs. teachers' src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3697-260x185.jpg' width='260' height='185' title='BH3A3697' alt=''/></a> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3702-1030x687.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3702.jpg' class='lightbox ' data-onclick='5' title='St. Elizabeth Seton teachers team' itemprop="contentURL"><img data-avia-tooltip='St. Elizabeth Seton teachers team' src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3702-260x185.jpg' width='260' height='185' title='BH3A3702' alt=''/></a> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3703-1030x687.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3703.jpg' class='first_thumb lightbox ' data-onclick='6' title='St. Thomas More Middle School students vs. teachers' itemprop="contentURL"><img data-avia-tooltip='St. Thomas More Middle School students vs. teachers' src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3703-260x185.jpg' width='260' height='185' title='BH3A3703' alt=''/></a> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3710-1030x687.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3710.jpg' class='lightbox ' data-onclick='7' title='St. Thomas More Middle School students vs. teachers' itemprop="contentURL"><img data-avia-tooltip='St. Thomas More Middle School students vs. teachers' src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3710-260x185.jpg' width='260' height='185' title='BH3A3710' alt=''/></a> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3716-1030x687.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3716.jpg' class='lightbox ' data-onclick='8' title='Deacon Larry Kopriva during warmups' itemprop="contentURL"><img data-avia-tooltip='Deacon Larry Kopriva during warmups' src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3716-260x185.jpg' width='260' height='185' title='BH3A3716' alt=''/></a> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3725-687x1030.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3725.jpg' class='lightbox ' data-onclick='9' title='Fr. Edmund Yainao warming up' itemprop="contentURL"><img data-avia-tooltip='Fr. Edmund Yainao warming up' src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3725-260x185.jpg' width='260' height='185' title='BH3A3725' alt=''/></a> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3730-1030x687.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3730.jpg' class='lightbox ' data-onclick='10' title='Msgr. Michael Woster signs basketball cards for kids' itemprop="contentURL"><img data-avia-tooltip='Msgr. Michael Woster signs basketball cards for kids' src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3730-260x185.jpg' width='260' height='185' title='BH3A3730' alt=''/></a> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3731-1030x687.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3731.jpg' class='first_thumb lightbox ' data-onclick='11' title='' itemprop="contentURL"><img src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3731-260x185.jpg' width='260' height='185' title='BH3A3731' alt=''/></a> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3734-687x1030.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3734.jpg' class='lightbox ' data-onclick='12' title='Rapid City Mayor Steve Allend' itemprop="contentURL"><img data-avia-tooltip='Rapid City Mayor Steve Allend' src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3734-260x185.jpg' width='260' height='185' title='BH3A3734' alt=''/></a> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3738-687x1030.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3738.jpg' class='lightbox ' data-onclick='13' title='Mayor Allender shakes hands with Bishop Robert Gruss after reading the proclamation' itemprop="contentURL"><img data-avia-tooltip='Mayor Allender shakes hands with Bishop Robert Gruss after reading the proclamation ' src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3738-260x185.jpg' width='260' height='185' title='BH3A3738' alt=''/></a> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3737-1030x687.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3737.jpg' class='lightbox ' data-onclick='14' title='Referees wait for the start of the game.' itemprop="contentURL"><img data-avia-tooltip='Referees wait for the start of the game.' src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3737-260x185.jpg' width='260' height='185' title='BH3A3737' alt=''/></a> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3746-1030x687.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3746.jpg' class='lightbox ' data-onclick='15' title='Fr. John Paul Trask during team introductions' itemprop="contentURL"><img data-avia-tooltip='Fr. John Paul Trask during team introductions' src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3746-260x185.jpg' width='260' height='185' title='BH3A3746' alt=''/></a> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3752-1030x687.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3752.jpg' class='first_thumb lightbox ' data-onclick='16' title='Fr. Edmund Yainao during team introductions' itemprop="contentURL"><img data-avia-tooltip='Fr. Edmund Yainao during team introductions' src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3752-260x185.jpg' width='260' height='185' title='BH3A3752' alt=''/></a> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3757-1030x687.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3757.jpg' class='lightbox ' data-onclick='17' title='Coach Bishop Gruss pumps up his team after team introductions' itemprop="contentURL"><img data-avia-tooltip='Coach Bishop Gruss pumps up his team after team introductions' src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3757-260x185.jpg' width='260' height='185' title='BH3A3757' alt=''/></a> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3758-1030x687.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3758.jpg' class='lightbox ' data-onclick='18' title='Fr. John Paul Trasks prepares to take a free throw' itemprop="contentURL"><img data-avia-tooltip='Fr. John Paul Trasks prepares to take a free throw' src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3758-260x185.jpg' width='260' height='185' title='BH3A3758' alt=''/></a> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3760-1030x687.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3760.jpg' class='lightbox ' data-onclick='19' title='The STM team and priests line up during a technical foul' itemprop="contentURL"><img data-avia-tooltip='The STM team and priests line up during a technical foul' src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3760-260x185.jpg' width='260' height='185' title='BH3A3760' alt=''/></a> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3762-1030x687.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3762.jpg' class='lightbox ' data-onclick='20' title='Fr. Marck McCormick brings the ball down the court' itemprop="contentURL"><img data-avia-tooltip='Fr. Marck McCormick brings the ball down the court' src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3762-260x185.jpg' width='260' height='185' title='BH3A3762' alt=''/></a> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3763-1030x687.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3763.jpg' class='first_thumb lightbox ' data-onclick='21' title='Fr. Edmund Yainao takes a three-point shot' itemprop="contentURL"><img data-avia-tooltip='Fr. Edmund Yainao takes a three-point shot' src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3763-260x185.jpg' width='260' height='185' title='BH3A3763' alt=''/></a> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3765-1030x687.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3765.jpg' class='lightbox ' data-onclick='22' title='Fr. Grant Gerlach shoots a jumper' itemprop="contentURL"><img data-avia-tooltip='Fr. Grant Gerlach shoots a jumper' src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3765-260x185.jpg' width='260' height='185' title='BH3A3765' alt=''/></a> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3785-1030x687.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3785.jpg' class='lightbox ' data-onclick='23' title='Fr. Matt Fallgren looks to pass the the ball' itemprop="contentURL"><img data-avia-tooltip='Fr. Matt Fallgren looks to pass the the ball' src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3785-260x185.jpg' width='260' height='185' title='BH3A3785' alt=''/></a> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3790-1030x687.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3790.jpg' class='lightbox ' data-onclick='24' title='Msgr. Michael Woster dribbles around the court' itemprop="contentURL"><img data-avia-tooltip='Msgr. Michael Woster dribbles around the court' src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3790-260x185.jpg' width='260' height='185' title='BH3A3790' alt=''/></a> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3794-1030x687.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3794.jpg' class='lightbox ' data-onclick='25' title='Bishop Gruss (middle) shoots t-shirts into the crowd' itemprop="contentURL"><img data-avia-tooltip='Bishop Gruss (middle) shoots t-shirts into the crowd' src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3794-260x185.jpg' width='260' height='185' title='BH3A3794' alt=''/></a> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3803-1030x687.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3803.jpg' class='first_thumb lightbox ' data-onclick='26' title='Fr. James Hoerter, Fr. Mark McCromick, and Fr. Edmund Yainao cheer for a basket' itemprop="contentURL"><img data-avia-tooltip='Fr. James Hoerter, Fr. Mark McCromick, and Fr. Edmund Yainao cheer for a basket' src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3803-260x185.jpg' width='260' height='185' title='BH3A3803' alt=''/></a> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3804-1030x687.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3804.jpg' class='lightbox ' data-onclick='27' title='The Men in Black WIN!!!' itemprop="contentURL"><img data-avia-tooltip='The Men in Black WIN!!!' src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3804-260x185.jpg' width='260' height='185' title='BH3A3804' alt=''/></a> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3815-1030x687.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3815.jpg' class='lightbox ' data-onclick='28' title='St. Thomas More basketball team' itemprop="contentURL"><img data-avia-tooltip='St. Thomas More basketball team' src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3815-260x185.jpg' width='260' height='185' title='BH3A3815' alt=''/></a> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3817-1030x687.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3817.jpg' class='lightbox ' data-onclick='29' title='The Men in Black pose with the St. Thomas More Mission Team' itemprop="contentURL"><img data-avia-tooltip='The Men in Black pose with the St. Thomas More Mission Team' src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/BH3A3817-260x185.jpg' width='260' height='185' title='BH3A3817' alt=''/></a> <a href='http://rapidcitydiocese.org/wp-content/uploads/2017/02/IMAG2103-1030x687.jpg' data-rel='gallery-1' data-prev-img='http://rapidcitydiocese.org/wp-content/uploads/2017/02/IMAG2103.jpg' class='lightbox ' data-onclick='30' title='The Men in Black' itemprop="contentURL"><img data-avia-tooltip='The Men in Black' src='http://rapidcitydiocese.org/wp-content/uploads/2017/02/IMAG2103-260x185.jpg' width='260' height='185' title='IMAG2103' alt=''/></a></div></div>
</div></div></main><!-- close content main element --> <!-- section close by builder template --><aside class='sidebar sidebar_right smartphones_sidebar_active alpha units' role="complementary" itemscope="itemscope" itemtype="https://schema.org/WPSideBar"><div class='inner_sidebar extralight-border'><section id="search-2" class="widget clearfix widget_search">

<form action="http://rapidcitydiocese.org/" id="searchform" method="get" class="">
	<div>
		<input type="submit" value="" id="searchsubmit" class="button avia-font-entypo-fontello"/>
		<input type="text" id="s" name="s" value="" placeholder='Search'/>
			</div>
</form><span class="seperator extralight-border"></span></section></div></aside>		</div><!--end builder template--></div><!-- close default .container_wrap element -->						<div class='container_wrap footer_color' id='footer'>

					<div class='container'>

						<div class='flex_column av_one_fourth  first el_before_av_one_fourth'><section id="text-2" class="widget clearfix widget_text"><h3 class="widgettitle">Chancery Office</h3>			<div class="textwidget"><p>606 Cathedral Drive<br/>
Rapid City, SD 57701<br/>
(605) 343-3541</p>
</div>
		<span class="seperator extralight-border"></span></section></div><div class='flex_column av_one_fourth  el_after_av_one_fourth  el_before_av_one_fourth '><section id="text-3" class="widget clearfix widget_text"><h3 class="widgettitle">Chancery Annex at Terra Sancta</h3>			<div class="textwidget"><p>2101 City Springs Rd Ste 200<br/>
Rapid City, SD 57702<br/>
(605) 716-5214</p>
</div>
		<span class="seperator extralight-border"></span></section></div><div class='flex_column av_one_fourth  el_after_av_one_fourth  el_before_av_one_fourth '><section id="text-24" class="widget clearfix widget_text"><h3 class="widgettitle">Terra Sancta Retreat Center</h3>			<div class="textwidget"><p>2101 City Springs Rd, Ste 300<br/>
Rapid City , SD 57702<br/>
(605) 716-0925<br/>
<a href="mailto:stay@terrasancta.org" target="_blank">stay@terrasancta.org</a></p>
</div>
		<span class="seperator extralight-border"></span></section></div><div class='flex_column av_one_fourth  el_after_av_one_fourth  el_before_av_one_fourth '><section id="text-31" class="widget clearfix widget_text"><h3 class="widgettitle">Safe Environment</h3>			<div class="textwidget"><p><a href="http://www.rapidcitydiocese.org/safe-environment/">Click here to learn more</a></p>
</div>
		<span class="seperator extralight-border"></span></section><section id="text-25" class="widget clearfix widget_text"><h3 class="widgettitle">Victim Assistance Coordinator</h3>			<div class="textwidget"><p>Barbara Scherr<br/>
(605) 209-3418</p>
</div>
		<span class="seperator extralight-border"></span></section></div>

					</div>


				<!-- ####### END FOOTER CONTAINER ####### -->
				</div>

	


			

			
				<footer class='container_wrap socket_color' id='socket' role="contentinfo" itemscope="itemscope" itemtype="https://schema.org/WPFooter">
                    <div class='container'>

                        <span class='copyright'>© Copyright 2015 | Diocese of Rapid City | Powered by <a href="http://www.kolbemedia.com" target="_blank">Kolbe Media </a> </span>

                        
                    </div>

	            <!-- ####### END SOCKET CONTAINER ####### -->
				</footer>


					<!-- end main -->
		</div>
		
		<a class='avia-post-nav avia-post-prev with-image' href='http://rapidcitydiocese.org/director-youth-young-adult/'>    <span class='label iconfont' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'></span>    <span class='entry-info-wrap'>        <span class='entry-info'>            <span class='entry-title'>Employment Opportunity: Director of Youth and Young Adult Ministry</span>            <span class='entry-image'><img width="80" height="80" src="http://rapidcitydiocese.org/wp-content/uploads/2014/06/Crest14-200x200.png" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="http://rapidcitydiocese.org/wp-content/uploads/2014/06/Crest14-200x200.png 200w, http://rapidcitydiocese.org/wp-content/uploads/2014/06/Crest14-36x36.png 36w, http://rapidcitydiocese.org/wp-content/uploads/2014/06/Crest14-180x180.png 180w, http://rapidcitydiocese.org/wp-content/uploads/2014/06/Crest14-120x120.png 120w" sizes="(max-width: 80px) 100vw, 80px"/></span>        </span>    </span></a><!-- end wrap_all --></div>

		<script type="text/javascript">var gmapstyles='default';</script>		
		
 <script type='text/javascript'>var avia_framework_globals=avia_framework_globals||{};avia_framework_globals.frameworkUrl='http://rapidcitydiocese.org/wp-content/themes/enfold/framework/';avia_framework_globals.installedAt='http://rapidcitydiocese.org/wp-content/themes/enfold/';avia_framework_globals.ajaxurl='http://rapidcitydiocese.org/wp-admin/admin-ajax.php';</script>
 
 <style type='text/css'>#top #wrap_all .avia-gallery-1 .avia-gallery-thumb a{width:20%}</style><link rel='stylesheet' id='eventon_dynamic_styles-css' href='//rapidcitydiocese.org/wp-content/plugins/eventON/assets/css/A.eventon_dynamic_styles.css,qver=4.7.2.pagespeed.cf.wfep-mZyID.css' type='text/css' media='all'/>
<script type='text/javascript' src='http://rapidcitydiocese.org/wp-includes/js/underscore.min.js,qver=1.8.3.pagespeed.jm.mGiwqwtvc5.js'></script>
<script type='text/javascript' src='http://rapidcitydiocese.org/wp-content/themes/enfold/js/avia.js,qver=3.pagespeed.jm.RIFmbkUZFc.js'></script>
<script type='text/javascript' src='http://rapidcitydiocese.org/wp-content/themes/enfold/js/shortcodes.js?ver=3'></script>
<script type='text/javascript' src='http://rapidcitydiocese.org/wp-content/themes/enfold/js/aviapopup/jquery.magnific-popup.min.js,qver=2.pagespeed.jm.AAUdvL50L_.js'></script>
<script type='text/javascript'>var mejsL10n={"language":"en-US","strings":{"Close":"Close","Fullscreen":"Fullscreen","Turn off Fullscreen":"Turn off Fullscreen","Go Fullscreen":"Go Fullscreen","Download File":"Download File","Download Video":"Download Video","Play":"Play","Pause":"Pause","Captions\/Subtitles":"Captions\/Subtitles","None":"None","Time Slider":"Time Slider","Skip back %1 seconds":"Skip back %1 seconds","Video Player":"Video Player","Audio Player":"Audio Player","Volume Slider":"Volume Slider","Mute Toggle":"Mute Toggle","Unmute":"Unmute","Mute":"Mute","Use Up\/Down Arrow keys to increase or decrease volume.":"Use Up\/Down Arrow keys to increase or decrease volume.","Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds."}};var _wpmejsSettings={"pluginPath":"\/wp-includes\/js\/mediaelement\/"};</script>
<script type='text/javascript' src='http://rapidcitydiocese.org/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=2.22.0'></script>
<script src="http://rapidcitydiocese.org/wp-includes/js/mediaelement,_wp-mediaelement.min.js,qver==4.7.2+comment-reply.min.js,qver==4.7.2.pagespeed.jc.7L2FR4LjEf.js"></script><script>eval(mod_pagespeed_9RlM$53Un5);</script>
<script>eval(mod_pagespeed_o_p_k6CRzx);</script>
<script type='text/javascript'>var pplb_ajax={"ajaxurl":"http:\/\/rapidcitydiocese.org\/wp-admin\/admin-ajax.php"};</script>
<script src="http://rapidcitydiocese.org/wp-content,_plugins,_protected-posts-logout-button,_logout.js+wp-includes,_js,_wp-embed.min.js,qver==4.7.2.pagespeed.jc.B9YDnX5HSH.js"></script><script>eval(mod_pagespeed_kUA8PS$q4U);</script>
<script>eval(mod_pagespeed_vvygFO_kog);</script>
<a href='#top' title='Scroll to top' id='scroll-top-link' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'><span class="avia_hidden_link_text">Scroll to top</span></a>

<div id="fb-root"></div>
</body>
</html>
